Search
Other Articles Anywhere questions
Forum

Modules showing on child items in Hikashop Version 3

David Jakob's Avatar David Jakob
Hi Peter

I'm setting up a site using the latest hikashop version 3 and latest everything else.
I have tried everything to make some standard modules only show on the "front page" (categories listing) but they still show on all the subsequent pages.
The site is being built here : transmetra.imaufbau.ch

The modules concerned are the ones containing "Bürozeiten" (a custom html module) and the one at the bottom of the page "Aus unserem Blog"

A great example is here : transmetra.imaufbau.ch/Produkt/pyroview-160l , where you can also the tabs plugin working. But those two modules really should not be there.

I hop you can help.
Regards
Peter van Westen's Avatar Peter van Westen ADMIN
So you only want it on the home page?
That should work with (only) using the Home Page assignment?
So not the Menu Item assignment, but the one under it.
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
The home page is the categories list.
I've set it to the home page only as suggested, but no luck - see transmetra.imaufbau.ch/Produktgruppe/seminare-schulungen
Peter van Westen's Avatar Peter van Westen ADMIN
Can you give me (super) admin and (s)ftp access so I can take a look?
You can use the 'Hidden text' button in the forum editor to hide the confidential information.
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
Ok - here you go :
Confidential information:
(hidden)


Thanks for your help
Peter van Westen's Avatar Peter van Westen ADMIN
Ah, ok, this is a Gantry Particle. Not a normal module placed in a normal module position.
The issue is with Gantry.
Also see: www.regularlabs.com/forum/advancedmodule...-edit-particle#67740
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
Ok - I'll check that out, but the "Bürozeiten" is a standard joomla custom Module

Note - I have now reinstalled Gantry Version 5.4.5 as discussed on github and the problem still persists.

Maybe something to do with the new version of hikashop?
Peter van Westen's Avatar Peter van Westen ADMIN
The 'Bürozeiten' module is not assigned to a module position. How are you placing it there?
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
I use gantry layout with a module instance
Peter van Westen's Avatar Peter van Westen ADMIN
Well, there is the issue. With Gantry not being compatible with Advanced Module Manager.
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
That's a bit of a blow - there are thousands of gantry sites.

And I use the plugin on some other gantry sites. I still suspect it has something to do with hika shop

If I assign the modules to pages other than hikashop, it works fine.
Peter van Westen's Avatar Peter van Westen ADMIN
Could be.
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
So, what do you suggest?
Are you intouch with the hikshop people? Can you find out what's different in their new version?
Peter van Westen's Avatar Peter van Westen ADMIN
Please try the latest development version from:
www.regularlabs.com/development-releases
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
Ok, tried that, stiil no success 🙁
Peter van Westen's Avatar Peter van Westen ADMIN
You are excluding that module by HikaShop categories. However, you have no page types selected.
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
Whatever combination I try, I still see both modules on every hikashop page
Peter van Westen's Avatar Peter van Westen ADMIN
Regarding the 'Bürozeiten' module. Can you explain exactly on what urls you do and don't want it to show, as this is not clear to me.
Please post a rating at the Joomla! Extensions Directory
David Jakob's Avatar David Jakob
I would like it to appear on the landing page and that's all. Does that help?
Peter van Westen's Avatar Peter van Westen ADMIN
The assignment in Advanced Module Manager is getting triggered and returns the correct result.

So it seems like whatever is placing the modules is not listening to what the ModuleHelper class (intercepted by Advanced Module Manager) does concerning assignments.
This issue seems outside the control of Advanced Module Manager.
Please post a rating at the Joomla! Extensions Directory
You can only post on the extension support forum if you have an active subscription and you log in

Buy a Pro subscription