Simple User Notes

User Notes menu item from admin area disappeared after plugin installation.

3 years 5 months ago #72624

Anastasios Dionysiou's Avatar Anastasios Dionysiou

Following initial installation of "Simple User Notes", I created a note, saved it and the menu item "User Notes" disappeared.
When I tried uninstalling the plugin I received an error "Error Uninstalling" but the plugin was uninstalled anyway and the menu item "User Notes" in the admin area re-appeared.
Unfortunately the user notes I had created were no longer there.
I tried installing the plugin a second time (το see if I can duplicate this action) and as soon as I created a Note Category the menu item for User Notes disappeared again.

When I tried to uninstall the plugin, again I received the same error, but the plugin was uninstalled.

and the User Menu Item re-appeared again.

System Information

PHP Built On Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64
Database Version 5.5.55-0+deb8u1
Database Collation utf8_general_ci
Database Connection Collation utf8mb4_general_ci
PHP Version 7.0.19-1~dotdeb+8.1
Web Server Apache/2.4.10 (Debian)
WebServer to PHP Interface fpm-fcgi
Joomla! Version Joomla! 3.7.2 Stable [ Amani ] 22-May-2017 09:46 GMT
Joomla! Platform Version Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

3 years 5 months ago #72627

Peter van Westen's Avatar Peter van Westen Admin

That's pretty much the whole idea behind Simple User Notes.
It removes the core User Notes menu items and categories and replaces this with a simple textareas field in the user edit view.

So yes, it is correct that those menu items disappear.

3 years 5 months ago #72637

Anastasios Dionysiou's Avatar Anastasios Dionysiou

Hi Peter,

Thank you so much for your immediate reply.
Apparently I did not pay close attention to your detailed instructions.

I guess the error during uninstallation of the plugin is probably my fault then.

Have a great evening