Search
Other Extension Manager questions
Forum

Everything has vanished

Satyajit Deodhar's Avatar Satyajit Deodhar
Hi,

In my latest version 3 Joomla site, I just updated two of your excellent extensions, Sliders and Tabs and now all 9 extensions and the Extension Manager have disappeared. The Libraries/Regular Labs directory only has one file in it now, the script.install.php

I have restored backups of the Libraries/Regular Labs directory and the MySQL database and the many red error messages have disappeared so the website seems to be working ok now. The only issue I can see at the moment is the Extension Manager has a lot of blanks in it - the blue buttons are all blank and there is no written indication of which extensions are installed, however, all 9 Uninstall Xs are there.

How do I fix this, and make sure this doesn't happen again when I update the extensions, please?

Thanks,

Andy
Peter van Westen's Avatar Peter van Westen ADMIN
Can you try reinstalling the Extension Manager?
Please post a rating at the Joomla! Extensions Directory
Satyajit Deodhar's Avatar Satyajit Deodhar
That worked, Peter, thank you for such a speedy response, however Tabs and Sliders show as 8.2.2 (up to date) in the Extension Manager, yet on the Joomla Update page they show as 8.2.0. I am afraid of reinstalling Tabs and Sliders in case it deletes the Libraries/Regular Labs directory contents again. Please would you look into the cause of this, Peter?
Peter van Westen's Avatar Peter van Westen ADMIN
I recommend you try it on the test version of your website first.
Please post a rating at the Joomla! Extensions Directory
Satyajit Deodhar's Avatar Satyajit Deodhar
I don't have a test version of this website, however I have updated both extensions on a similar website and there were no problems.

Is it likely to have been a one-time problem and so it should be safe to reinstall the two extensions again?
Peter van Westen's Avatar Peter van Westen ADMIN
It seems things act weird if there is a little hiccup during installation. I am looking into it and trying to rewrite the whole installer script as a result.

I recommend you just update.
If it breaks again, copy these folders to your server manually from the zip file:
/libraries/regularlabs
/media/regularlabs (media files are in the zip file under /libraries/regularlabs/media)
/plugins/system/regularlabs
Please post a rating at the Joomla! Extensions Directory
Satyajit Deodhar's Avatar Satyajit Deodhar
Thank you so much Peter,

I am connected to the internet via cellular 4G and the connection is a bit variable at the moment.

Have a great day,

Andy
You can only post on this forum if you log in