Search
Other Extension Manager questions
Forum

Error after upgrading to 7.4.6

Simon Kloostra's Avatar Simon Kloostra
Afte upgrading to the latest version (7.4.6) the extension gives me the following error:
Warning: Declaration of PlgSystemEmailProtector::loadStylesAndScripts($buffer) should be compatible with RegularLabs\Library\Plugin::loadStylesAndScripts(&$buffer) in /home/xxxxx/public_html/plugins/system/emailprotector/emailprotector.php on line 66
Removing (or reinstalling) the emailprotector extension did not solve the issue, nor did re-installing a fresh download of Extension Manager.
I have also updated the other Regularlabs extensions, did not change anything.

To rule out a temporary issue, like I had before, I restored a backup and tried again, but this time exactly the same happened.
For now, I have again restored the pre-error situation, hoping for a fix.

By the way, my other sites sofar did not have this issue.
Peter van Westen's Avatar Peter van Westen ADMIN
Try disabling the php error reporting (in your Global Config) and try to update all Regular Labs extensions.
Please post a rating at the Joomla! Extensions Directory
Peter van Westen's Avatar Peter van Westen ADMIN
If that fails, try disabling all Regular Labs system plugins before updating them.
Please post a rating at the Joomla! Extensions Directory
Simon Kloostra's Avatar Simon Kloostra
Php error reporting was already set to None. But the trick with the plugins worked, thanks.
Peter van Westen's Avatar Peter van Westen ADMIN
Ok, great.

I have had other reports that say switching off gzip might help too.

But anyway, this should be a 1-time issue. There had to be extension-wide changes to make preparations for J4.
Please post a rating at the Joomla! Extensions Directory
You can only post on this forum if you log in