Extension Manager

Content-Encoding-Error

1 month 1 week ago #93731

Schmakowski, Boris's Avatar Schmakowski, Boris

Hi Peter,

I tried to update RegLabs on two different projects, two different providers.
In both cases, after running the update for the Extensions Manager both sites stoped working - FE end BE.
Any idea?

Both projects are running on PHP 7.3 and Joomla 3.9.21.
In both cases I guess I need the help of each provider to restart the apache.

Best, Boris

https://www.dropbox.com/s/5590nvadvs57frz/Bildschirmfoto%202020-09-14%20um%2013.26.23.png?dl=0

1 month 1 week ago #93734

Peter van Westen's Avatar Peter van Westen Admin

No idea. Looks like a database issue???

Best to ask your provider what is wrong.

PS: I am running and testing my sites on php 7.3 with no issues.

1 month 1 week ago #93739

Schmakowski, Boris's Avatar Schmakowski, Boris

I guess it has sometging to do with GZIP.

Restart of the apache did not help.
Editing the config.php of Joomla public $gzip = '1'; -> public $gzip = '0'; brings the site back online.
Actullay with this warnings:
>> FE
Warning: Declaration of PlgSystemSliders::loadStylesAndScripts($buffer) should be compatible with RegularLabs\Library\Plugin::loadStylesAndScripts(&$buffer) in .../plugins/system/sliders/sliders.php on line 66
Warning: Declaration of PlgSystemTabs::loadStylesAndScripts($buffer) should be compatible with RegularLabs\Library\Plugin::loadStylesAndScripts(&$buffer) in .../plugins/system/tabs/tabs.php on line 66
Warning: Declaration of PlgSystemEmailProtector::loadStylesAndScripts($buffer) should be compatible with RegularLabs\Library\Plugin::loadStylesAndScripts(&$buffer) in .../plugins/system/emailprotector/emailprotector.php on line 99
<<

I will now try to update the rest and give you a feedback about.

It looks to me right now, if GZIP ist activated and RegularLabs Extension Manager is updated, site stops working … (?)

Best,
Boris

1 month 1 week ago #93740

Peter van Westen's Avatar Peter van Westen Admin

Also, switching off PHP error reporting during updating could help.

1 month 1 week ago #93744

Schmakowski, Boris's Avatar Schmakowski, Boris

Hi Peter,

I can confirm, while tested on 5 different Joomla-projects running at webspaces of 4 different providers:

In three cases after updating RegularLabs Extension Manager, the sites stopped working with the error
>> cannot decode raw data NSURLErrorDomain:-1015 << (FE and BE)
After editing the config public $gzip = '1'; -> public $gzip = '0'; sites are back online and able to update the rest.

At two others projects I was able to run all RegLabs updates without any problems, even as GZIP ist activated.

Unfortunate I can't analyse what the differences are between the settings of the different providers.
I have a lot more projects to update … so if you want me for testing, just let me know – I will not update all of them today 😉

Best,
Boris

1 month 1 week ago #93747

Peter van Westen's Avatar Peter van Westen Admin

I am aware that updating 1 can cause errors (warnings) for the ones not yet updated.
So safest is to switch off error reporting while doing the updates.

The Regular Labs Extension Manager does try to turn this off for the script that gets loaded during the update. But depending on the server, that might not work.

1 month 1 week ago #93751

Schmakowski, Boris's Avatar Schmakowski, Boris

OK, I see.

As I got one more project to update, where I am pretty sure to run into the same, as it is living on one the same providers webspace, where …
… you suggest to test the follwoing:
- PHP error reporting = off
- GZIP = on
- Update RegLabs Ex Manager
and see what happens? 😉

I will do so … ^^
Best,
Boris

1 month 1 week ago #93754

Peter van Westen's Avatar Peter van Westen Admin

Yup...

1 month 1 week ago #93755

Peter van Westen's Avatar Peter van Westen Admin

And otherwise: this should be a 1-time issue.
I was forced to make some changes in the Regular Labs Library in preparation of Joomla 4.
All RL extensions make use of that Library.

1 month 1 week ago #93762

Schmakowski, Boris's Avatar Schmakowski, Boris

And so I did … with warnings=off and gzip=on the update-process runs perfectly on a webspace where I had trouble before.

Thx!

And good to know, if it runs somewhere else in the same problem, it could help to set gzip=off.

Best,
Boris

1 month 1 week ago #93780

Peter van Westen's Avatar Peter van Westen Admin

Ok, thanks for the feedback!