Search
Other Email Protector questions
Forum

Email protector works, but the email disappears and I cannot style it

Brian Peat's Avatar Brian Peat
Confidential information:
(hidden)


On my site I have an email at the very top. It was in a custom module and wasn't being protected. I thought it would have been as email protector protects all modules/components even 3rd party, but that was my mistake. I turned on "prepare content" which seems to have solved the problem.

But now the content takes up 0 height. I change that in CSS but I still don't see the content and it doesn't take any of the colour values that I ask it to take.

What's the solution in this instance?

Here's the CSS I applied in case it helps you.
.cloaked_email.ep_35b57322, .cloaked_email.ep_35b57322 * {
color: blue;
width: 100%;
height: 40px;
display: inline-block;
}
Peter van Westen's Avatar Peter van Westen ADMIN
Your website is not loading the required Email Protector javascript file.
It looks like your template (or some extension) is removing this.
Please post a rating at the Joomla! Extensions Directory
Brian Peat's Avatar Brian Peat
Maybe it is JCH optimise which is adding it all to a single JS file.
Peter van Westen's Avatar Peter van Westen ADMIN
Maybe. Try disabling that.
Please post a rating at the Joomla! Extensions Directory
Brian Peat's Avatar Brian Peat
I've turned off JCH but the problem is still there. Take a look now, can you see the JS you speak of?
Peter van Westen's Avatar Peter van Westen ADMIN
So the issue is not a javascript file, but inline javascript code that is missing.
This should be somewhere in the head section of your HTML output, and it isn't.
var emailProtector=emailProtector||...
So again, this can be your template or some extension stripping it. But it is not something I can solve through Email Protector.
Please post a rating at the Joomla! Extensions Directory
Brian Peat's Avatar Brian Peat
This was caused by Litespeed Cache. I have disabled it, hope that helps someone else.
You can only post on this forum if you log in