Search
Other CDN for Joomla! questions
Forum

Reverts to NOT SECURE and css strange

Mick Graham's Avatar Mick Graham
My site is set to full https: but when the plugin is activated the site reverts to Non Secure and the css is all over the place.

I have check on Amazon Cloudfront and forced all the options to https: only but it doesnt seem to make a difference.

Any ideas?

rgds
Mick
www.valencia2alicante.properties
Peter van Westen's Avatar Peter van Westen ADMIN
Are the new urls in your html output using the https protocol?
Please post a rating at the Joomla! Extensions Directory
Mick Graham's Avatar Mick Graham
Sorry, I wouldnt know where to look for that.
Can you give me more information?
Peter van Westen's Avatar Peter van Westen ADMIN
Use the 'view source' option in your browser when visiting your website.
Please post a rating at the Joomla! Extensions Directory
Peter van Westen's Avatar Peter van Westen ADMIN
That is the base tag. Not the url of one of your media files (which CDN for Joomla! changes to use the cdn url).

I advise you to read the documentation first to understand what CDN for Joomla! actually does and how it works.

regularlabs.com/cdnforjoomla
Please post a rating at the Joomla! Extensions Directory
Mick Graham's Avatar Mick Graham
Thanks, Im familiar with what it does as I bought and installed the software.

I am merely asking for some support.

This is the difference when the component is enabled:
<link href="//d6ek70ckjeb90.cloudfront.net/templates/valencia2alicanteproperties/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />

and disabled:
<link href="/templates/valencia2alicanteproperties/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />

clearly your plugin is using amazon cloudfront, however the CSS is incorrect on the page and the page is showing as non secure.
I had followed all your instructions and would like to know in your experience if there is something I have done or not done.

Thanks
Mick
Peter van Westen's Avatar Peter van Westen ADMIN
So it looks like CDN for Joomla! is doing what it is supposed to do.
The leading '//' means it will use whatever protocol the current website is using.
You could try forcing https in the CDN for Joomla! system plugin settings.

If css or other files are not loading correctly from the cloudfront server (and refuse to be loaded via https), then that is down to the cloudfront setup.
That is outside the control of CDN for Joomla!
Questions about that should be directed to Amazon support.
Please post a rating at the Joomla! Extensions Directory
Mick Graham's Avatar Mick Graham
Hi Peter

Everything solved when I changed Use Relative Protocol to NO in the plugin.

Now it is working.

Thanks
Mick
Peter van Westen's Avatar Peter van Westen ADMIN
Ok, good to hear 🙂
Please post a rating at the Joomla! Extensions Directory
You can only post on the extension support forum if you have an active subscription and you log in

Buy a Pro subscription