Search
Other Better Preview questions
Forum

Preview content that is set for non-public access

Thaddeus James's Avatar Thaddeus James
Hi there, I have some content on a site that is only visible for Registered Users. When I try to use Better Preview on those articles it shows me the home page and I get this error: "A parent category has a non-public access level" .

I thought maybe if I went to Global Configuration > System > and set Shared Sessions to YES that would fix it. But with that set I get this error: "The most recent request was denied because it had an invalid security token. Please refresh the page and try again". No matter how many times I flush the cache or log out and back in, I can't get it to work.

Any help is greatly appreciated.

Thanks!
Peter van Westen's Avatar Peter van Westen ADMIN
The "Shared Sessions" option will create issues.

Better Preview should be able to show articles inside categories with non-public access levels.
Are you using core Joomla articles?
Please post a rating at the Joomla! Extensions Directory
Thaddeus James's Avatar Thaddeus James
Yes, straight core Joomla articles. The articles are in a category that is restricted to Registered Users. When I go to the article to edit it and hit Preview I see this error: A parent category has a non-public access level. This page may not available on your live site.
https://ibb.co/GTtLyCG
Peter van Westen's Avatar Peter van Westen ADMIN
Yes, that is correct!
All working as expected. That message is there to remind you that the article is not public.

But you can see the preview, right?
Please post a rating at the Joomla! Extensions Directory
Thaddeus James's Avatar Thaddeus James
No sir, it always opens the home page. I have tried it on several different articles in that category. It never opens the article I am editing, only the home page.
Peter van Westen's Avatar Peter van Westen ADMIN
Probably your template does not show any component content on the homepage.
Try changing the default menu item in the Better Preview system plugin settings.
Please post a rating at the Joomla! Extensions Directory
Thaddeus James's Avatar Thaddeus James
That did it. Thank you so much!!! Sorry to be a bother. I searched around a lot before I posted here. Sorry if this info was out there already and I missed it. As always, you are awesome!
Peter van Westen's Avatar Peter van Westen ADMIN
No problem. Happy it is solved for you. 🙂
Please post a rating at the Joomla! Extensions Directory
Thaddeus James's Avatar Thaddeus James
Hi there, This solved my issue for the private content, but now they cant preview the public content. It appears that I have to choose a public or a private default menu, which then blocks the other. Is there a setting that would allow them to be able to preview both types of content without switching the default menu every time?

Thanks!
Peter van Westen's Avatar Peter van Westen ADMIN
Setting a public default menu item (so not a guest only menu item) should work for any access level/usergroup.
Please post a rating at the Joomla! Extensions Directory
Thaddeus James's Avatar Thaddeus James
If I understand you correctly, that was my original problem.
If I set the a public default menu item, then they can not preview the private content.
If I set a private default menu item, they can not preview the public content.
There doesn't appear to be a way to preview public and private content.

Confidential information:
(hidden)


Thanks for the quick reply and the continued support!
Peter van Westen's Avatar Peter van Westen ADMIN
The answer about changing the default menu item was based on:
"Probably your template does not show any component content on the homepage."

That has nothing to do with access levels.

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button in the forum editor to hide the confidential information.
Please post a rating at the Joomla! Extensions Directory
Thaddeus James's Avatar Thaddeus James
UPDATE....
If I set the default menu item to be their private page, then they can preview everything EXCEPT articles in a blog.

Confidential information:
(hidden)


Thanks!
Peter van Westen's Avatar Peter van Westen ADMIN
Can you give your administrator url?
Simply going to /administrator gives an Access denied page.
Please post a rating at the Joomla! Extensions Directory
You can only post on the extension support forum if you have an active subscription and you log in

Buy a Pro subscription