Simple User Notes

Interference with Akeeba Admin Tools on Joomla 3.8.0

3 years 2 months ago #75014

Jim Grusendorf's Avatar Jim Grusendorf

After upgrading from Joomla 3.7.5 to 3.8.0, the Simple User Notes extension causes a problem with Akeeba Admin Tools. When viewing a PHP File Change Scanner report with more than about 1,300 items and selecting the drop-down to view All items, a blank page is returned. There is no PHP error reported. Disabling Simple User Notes fixes the problem. I have verified this on multiple sites.

3 years 2 months ago #75016

Peter van Westen's Avatar Peter van Westen Admin

Please check what php error breaks the page.
You can see php errors by setting the Error Reporting to 'Development' in the Global Configuration:


Or take a look at your php error log. Or enable php error reporting (via .htaccess for example).

3 years 2 months ago #75052

Jim Grusendorf's Avatar Jim Grusendorf

There is no error. I have "error_reporting = E_ALL" in my php.ini and I know error logging is working because I'm seeing "Wright has a deprecated constructor" warnings from a template on one site.

3 years 2 months ago #75054

Peter van Westen's Avatar Peter van Westen Admin

Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button in the forum editor to hide the confidential information.

3 years 2 months ago #75061

Jim Grusendorf's Avatar Jim Grusendorf

Credentials are below. You're probably familiar with Admin Tools, but just in case, the steps to reproduce are:

  • Components > Admin Tools > PHP File Change Scanner
  • Click View Report button next to report #1.
  • In the drop-down for the number of items to view, select All.

I know 5,000 items is a lot to view all at once, but it lets me mark all of them safe at once instead of doing a hundred at a time, 50 times.

The Simple User Notes extension is currently enabled. I've also tried changing plugin order, but it made no difference.

Confidential information:
(hidden)

3 years 2 months ago #75066

Peter van Westen's Avatar Peter van Westen Admin

Ok, found the problem.
It is fixed on your setup and in latest development release on:
www.regularlabs.com/development-releases

3 years 2 months ago #75113

Jim Grusendorf's Avatar Jim Grusendorf

Thanks, Peter. You're awesome!