Better Preview

Better Preview vs SH404SEF problem, again ;-)

1 year 4 months ago #87539

Sukinoz's Avatar Sukinoz

Hello Peter, and company

First of all, thanks again for your extensions. 😁

I have a problem with sh404sef creating sef-urls when the Better Preview is installed (uninstall it and the problem goes out).

The problem is that sh404sef do not create the sef-url if the article is Unpublish. As you know, this is necessary because when you copy an article (with the "Batch" button or with the "Save as" Copy button), you need to change the title and alias before the sef-url is created.

But with Better Preview installed, it seems that the SEF-Url is created although the article is unpublished.

A year ago I had a very similar problem and you solved it with the configuration: 👍
www.regularlabs.com/forum/betterpreview/...-vs-sh404sef-problem

1 year 4 months ago #87541

Andrea Malalana's Avatar Andrea Malalana Moderator

Eh this is a tough one. I know sh404sef tries to not store URLs for unpublished articles, but I don't know what method they use for that. It's weird that the behavior is different with Better Preview. You could try to ask sh404sef support if they figure out how to prevent it.

1 year 4 months ago #87542

Andrea Malalana's Avatar Andrea Malalana Moderator

Try to disable "Show URL Details" in Better Preview Plugin Settings -> View Site Options

1 year 4 months ago #87543

Peter van Westen's Avatar Peter van Westen Admin

Better Preview will pass the article/item urls through the Joomla SEF routing (which plugins like sh404sef can influence).
It does this for all articles regardless of the publish state.
How your SEF extension deals with that is outside the control of Better Preview.

1 year 4 months ago #87566

Sukinoz's Avatar Sukinoz

thanks, I understand.

from SH404SEF they said:

"Joomla URL creation process is very simple: when either Joomla or an extension (Better preview or any other one) needs the URL of a page, that extension asks Joomla for the URL. Joomla itself asks sh404SEF for the URL.
When that happens, sh404SEF creates the URL and store it in the database. Joomla does not tell us what the context is or when the request is coming from: we just a call saying "what's the SFE URL for index.php?option=com_content&view=article&id=12&Itemid=34" and we compute the SEF URL and store it in the database."

1 year 4 months ago #87567

Peter van Westen's Avatar Peter van Westen Admin

Well, there is your answer.
So you'll just have to deal with the way that works.

1 year 4 months ago #87568

Sukinoz's Avatar Sukinoz

Peter van Westen wrote:

Well, there is your answer.
So you'll just have to deal with the way that works.

yes, it is ok.

if anyone comes here with the same problem, just tell him: Before using the "save as copy" button, be sure that the alias of the new article is the correct one. 😉

1 year 4 months ago #87569

Sukinoz's Avatar Sukinoz

by the way... is this a kind of Easter egg? 😉
drive.google.com/file/d/1d5GOvBNefrSSEaNWN3ZgEmS4sHuNYwJc/view

1 year 4 months ago #87570

Peter van Westen's Avatar Peter van Westen Admin

yup!

1 year 4 months ago #87573

Andrea Malalana's Avatar Andrea Malalana Moderator

Andy Badwool wrote:

Try to disable "Show URL Details" in Better Preview Plugin Settings -> View Site Options
Have you tried this, by the way?

I believe removing the link info might avoid the links of unpublished articles getting seen by sh404sef.

1 year 4 months ago #87574

Sukinoz's Avatar Sukinoz

Andy Badwool wrote:

Andy Badwool wrote:
Try to disable "Show URL Details" in Better Preview Plugin Settings -> View Site Options
Have you tried this, by the way?

I believe removing the link info might avoid the links of unpublished articles getting seen by sh404sef.

I have tested it, but the same result.

In deed, I have put all the options to "no" (no button, no links, no nothing... 😲 ) but the same result.

The only positive result is to "disable" the Better Preview Plugin...