Add to Menu

MUlti-Language + FLEXIcontent

2 years 8 months ago #78849

Robert Stark's Avatar Robert Stark

I'm having a problem with creating menus.

The alias %1$s is already being used by %2$s menu item in the %3$s menu (remember it may be a trashed item).

Warning: json_decode() expects parameter 1 to be string, array given in /home/taichung/public_html/iis4/administrator/modules/mod_addtomenu/popup.php on line 41


It doesn't seem to handle CHinese Characters in the error message:
行事曆

If I have a Chinese Menu & English Menu - why can't they have the same alias?



When I go into the Joomla Menu Item and change the name it works:



FLEXIContent issued a fix here:
github.com/FLEXIcontent/flexicontent-cck/issues/852

not sure if it applies in this case.

2 years 8 months ago #78851

Peter van Westen's Avatar Peter van Westen Admin

Please try the latest development version from:
www.regularlabs.com/development-releases

2 years 8 months ago #78862

Robert Stark's Avatar Robert Stark

Thanks Peter,

I have tried that - but still same issue:




Version:


Steps to fix:

1. Change Alias:


2. Change alias to correct name - can save:


URL Works:
taichungdesigner.com/iis4/tw/teaching

2 years 8 months ago #78863

Robert Stark's Avatar Robert Stark

Now it only seems to fail on top level when I try to add to the root Main Menu (中文) - after I change it with the steps above - its ok with sub-menus.

2 years 8 months ago #78869

Peter van Westen's Avatar Peter van Westen Admin

Well, seems you already have a menu item called 'teaching'.
So isn't that expected behaviour?

If not, Can you give me (super) admin and (s)ftp access so I can take a look?
And tell me on what url I can see/reproduce the issue.
You can use the 'Hidden text' button in the forum editor to hide the confidential information.